The login screen is messed up

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
Alikiller
Peon
Peon
Posts: 4
Joined: 08 Aug 2009, 15:02
Location: Sweden,Goteborg
Contact:

The login screen is messed up

Post by Alikiller » 08 Aug 2009, 15:17

Image

http://img269.imageshack.us/img269/2020/78649397.png


The log in screen is messed up dunno why, i just downloaded it and i tried uninstalling and installing.

I use windows 7 64x
User avatar
Mpa4Hu
Peon
Peon
Posts: 58
Joined: 18 Jul 2009, 13:26

Re: The login screen is messed up

Post by Mpa4Hu » 08 Aug 2009, 15:22

i'm also using win7 x64 and i have no problems!
User avatar
Rotonen
TMW Adviser
TMW Adviser
Posts: 3154
Joined: 08 Sep 2004, 20:48
Location: Espoo, Finland

Re: The login screen is messed up

Post by Rotonen » 08 Aug 2009, 15:45

Try using up-to-date graphics drivers which actually have OpenGL support.
This message used to be meaningful.
Turmfalke
Novice
Novice
Posts: 350
Joined: 10 Aug 2008, 19:28
Location: Maligree's Wonderful Garden

Re: The login screen is messed up

Post by Turmfalke » 08 Aug 2009, 15:47

as I heared windows7 doesn't supports opengl so you might try to turn it off in your config file.
I stand beside the holy man
The monarchs fear my wrath
None may move the way I can
Ever the crooked path
a knight
User avatar
Rotonen
TMW Adviser
TMW Adviser
Posts: 3154
Joined: 08 Sep 2004, 20:48
Location: Espoo, Finland

Re: The login screen is messed up

Post by Rotonen » 08 Aug 2009, 15:50

You're wrong. Don't spread misinformation.

It does not support native OpenGL, but it still allows drivers to do it in a software translation layer. This produces correct OpenGL visuals. It causes a minor performance overhead, but in our case it is not significant.

Get up to date drivers instead of early beta drivers and you get OpenGL. (It was the same with Vista in the early days too.)
This message used to be meaningful.
Alikiller
Peon
Peon
Posts: 4
Joined: 08 Aug 2009, 15:02
Location: Sweden,Goteborg
Contact:

Re: The login screen is messed up

Post by Alikiller » 08 Aug 2009, 15:53

Turmfalke wrote:as I heared windows7 doesn't supports opengl so you might try to turn it off in your config file.

What config file :? :? :?

explain
Alikiller
Peon
Peon
Posts: 4
Joined: 08 Aug 2009, 15:02
Location: Sweden,Goteborg
Contact:

Re: The login screen is messed up

Post by Alikiller » 08 Aug 2009, 15:54

Rotonen wrote:You're wrong. Don't spread misinformation.

It does not support native OpenGL, but it still allows drivers to do it in a software translation layer. This produces correct OpenGL visuals. It causes a minor performance overhead, but in our case it is not significant.

Get up to date drivers instead of early beta drivers and you get OpenGL. (It was the same with Vista in the early days too.)

So i should update my drivers right?
Kill3rZ
Novice
Novice
Posts: 200
Joined: 17 Jun 2009, 12:45

Re: The login screen is messed up

Post by Kill3rZ » 08 Aug 2009, 16:28

It happened to me once. I just fixed it by turning off OpenGL in the setup window. The menu and everything came back to normal.
Matt
Knight
Knight
Posts: 1747
Joined: 07 Aug 2004, 11:47
Location: Germany->Bavaria

Re: The login screen is messed up

Post by Matt » 08 Aug 2009, 17:29

First try to update your graphic card driver, if there is still a problem your grapic card manufacturer sucks and you have to disable OpenGL, but first try to update your drivers!

To disable opengl open your config file (config.xml) in your

%userprofile%\.tmw

directory (just copy and paste that to the adress bar)
Alikiller
Peon
Peon
Posts: 4
Joined: 08 Aug 2009, 15:02
Location: Sweden,Goteborg
Contact:

Re: The login screen is messed up

Post by Alikiller » 08 Aug 2009, 18:37

I updated my graphic card and it worked Thanks everyone :D
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: 01 Nov 2007, 18:35
Location: Internet

Re: The login screen is messed up

Post by Jaxad0127 » 10 Aug 2009, 00:54

For future reference, newer client versions have a command-line option to disable OpenGL (--no-opengl). It only affects that session, so you'll still need to go into setup and disable it.
Image
Post Reply