PROBLEM COMPILING LATES GIT WITH CODEBLOCKS

Ask for help regarding any technical issue or report any bug or OS independent issues.
Post Reply
Habari
Novice
Novice
Posts: 249
Joined: 25 Nov 2007, 17:04

PROBLEM COMPILING LATES GIT WITH CODEBLOCKS

Post by Habari » 02 Jan 2010, 23:37

..........................
Last edited by Habari on 20 May 2010, 00:06, edited 1 time in total.
User avatar
ElvenProgrammer
TMW Adviser
TMW Adviser
Posts: 2526
Joined: 13 Apr 2004, 20:11
Location: Italy
Contact:

Re: PROBLEM COMPILING LATES GIT WITH CODEBLOCKS

Post by ElvenProgrammer » 13 Jan 2010, 12:54

I compiled the latest git on a fresh install of codeblocks/mingw and had no problems.
Can you give further details about your codeblocks setup?

Or maybe the problem has already been solved in recent commits and we can close the topic?

Regards
Habari
Novice
Novice
Posts: 249
Joined: 25 Nov 2007, 17:04

Re: PROBLEM COMPILING LATES GIT WITH CODEBLOCKS

Post by Habari » 13 Jan 2010, 15:17

...............
Last edited by Habari on 20 May 2010, 00:06, edited 1 time in total.
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: 01 Nov 2007, 18:35
Location: Internet

Re: PROBLEM COMPILING LATES GIT WITH CODEBLOCKS

Post by Jaxad0127 » 13 Jan 2010, 16:03

Maybe architecture mismatch. Make sure you're using 64bit if your computer is 64bit.
Image
Habari
Novice
Novice
Posts: 249
Joined: 25 Nov 2007, 17:04

Re: PROBLEM COMPILING LATES GIT WITH CODEBLOCKS

Post by Habari » 13 Jan 2010, 16:52

....................
Last edited by Habari on 20 May 2010, 00:06, edited 1 time in total.
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: 01 Nov 2007, 18:35
Location: Internet

Re: PROBLEM COMPILING LATES GIT WITH CODEBLOCKS

Post by Jaxad0127 » 13 Jan 2010, 19:14

Are you using the last release or the nightly build? You need to use the nightly.
Image
Habari
Novice
Novice
Posts: 249
Joined: 25 Nov 2007, 17:04

Re: PROBLEM COMPILING LATES GIT WITH CODEBLOCKS

Post by Habari » 13 Jan 2010, 22:29

.....................
Last edited by Habari on 20 May 2010, 00:06, edited 1 time in total.
User avatar
Freeyorp101
Administrator
Administrator
Posts: 710
Joined: 04 Nov 2008, 10:17
Location: New Zealand

Re: PROBLEM COMPILING LATES GIT WITH CODEBLOCKS

Post by Freeyorp101 » 14 Jan 2010, 01:18

Try

Code: Select all

git clone git://gitorious.org/mana/mana.git mana

---Freeyorp
(09:58:17) < tux9th> Freeyorp: your sig on the forums is kind of outdated
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: 01 Nov 2007, 18:35
Location: Internet

Re: PROBLEM COMPILING LATES GIT WITH CODEBLOCKS

Post by Jaxad0127 » 14 Jan 2010, 01:52

And I was talking about Code::Blocks, not TMW/Mana.
Image
User avatar
ElvenProgrammer
TMW Adviser
TMW Adviser
Posts: 2526
Joined: 13 Apr 2004, 20:11
Location: Italy
Contact:

Re: PROBLEM COMPILING LATES GIT WITH CODEBLOCKS

Post by ElvenProgrammer » 14 Jan 2010, 09:48

jaxad0127 wrote:Are you using the last release or the nightly build? You need to use the nightly.
Is this required for Win7?

Because I installed latest official release of CodeBlocks on WinXP 64bit and compiled successfully
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: 01 Nov 2007, 18:35
Location: Internet

Re: PROBLEM COMPILING LATES GIT WITH CODEBLOCKS

Post by Jaxad0127 » 14 Jan 2010, 14:35

Not sure. Might be mingw is too old too.
Image
Spekulyant
Peon
Peon
Posts: 13
Joined: 12 Aug 2009, 08:24

Re: PROBLEM COMPILING LATES GIT WITH CODEBLOCKS

Post by Spekulyant » 14 Jan 2010, 17:04

Try to remove enet folder from search directories in CodeBlocks.
User avatar
Rotonen
TMW Adviser
TMW Adviser
Posts: 3154
Joined: 08 Sep 2004, 20:48
Location: Espoo, Finland

Re: PROBLEM COMPILING LATES GIT WITH CODEBLOCKS

Post by Rotonen » 15 Jan 2010, 02:22

What is the exact error you are having? Without that it's pretty much a guessing game trying to help you.

My best guess would be that you have not told C::B where to find SDL.
This message used to be meaningful.
User avatar
Jaxad0127
TMW Adviser
TMW Adviser
Posts: 4209
Joined: 01 Nov 2007, 18:35
Location: Internet

Re: PROBLEM COMPILING LATES GIT WITH CODEBLOCKS

Post by Jaxad0127 » 15 Jan 2010, 02:34

Rotonen wrote:What is the exact error you are having? Without that it's pretty much a guessing game trying to help you.

My best guess would be that you have not told C::B where to find SDL.
The error is in the first post as has nothing to do with SDL (or something rather weird is going on). Maybe ask the Code::Blocks developers. They're far more familiar that we are with it.
Image
User avatar
Rotonen
TMW Adviser
TMW Adviser
Posts: 3154
Joined: 08 Sep 2004, 20:48
Location: Espoo, Finland

Re: PROBLEM COMPILING LATES GIT WITH CODEBLOCKS

Post by Rotonen » 15 Jan 2010, 03:02

Oopsie, my fault for not reading properly.

My apologies. Yes, my best revised guess hints at your mingw installation being borked up in some way. Nuke it from orbit and try with a fresh snapshot of mingw.
This message used to be meaningful.
Post Reply